Announcing Add-on SDK 1.2.1!

5

Hot on the heels of yesterday’s SDK 1.2 release, we have released Add-on SDK 1.2.1 to address a critical issue that surfaced in 1.2 which would have prevented add-ons from being distributed on https://addons.mozilla.org/en-US/firefox/. Thanks to community member Carey Tilden who reported this issue to the Jetpack mailing list!

This issue occurs if you create an xpi file for your addon with SDK version 1.2 and then upload it to the Addons site. There error you will see is:

Invalid minimum version number

Error: The minimum version that was specified is not an acceptable version number for the Mozilla product that it corresponds with.

To avoid this error, simply download Add-on SDK 1.2.1, replacing SDK 1.2. For more information about this release, please see the Release Notes.

If you are using the Add-on Builder, please note that we do not expect 1.2.1 to be deployed to Builder until 1PM tomorrow PDT ( Thursday, Oct. 19 ). Feel free to continue developing with Builder in the meantime but keep in mind that, until SDK 1.2.1 is deployed to Builder any xpi packages created will fail validation when uploading to the addons site.

Categories: builder, general, jetpack, sdk

5 responses

  1. Mingyi Liu

    I found the same minVersion issue when trying to upload my addon too. Great that you fixed it in 1.2.1.

    However, 1.2.1 showed the same error “ERROR: The system was unable to find the specified registry key or value.” as 1.1 when one tries to “bin\activate”. But 1.2 release notes clearly stated that this bug was fixed (and I confirmed it when I repacked my addon with 1.2).

    This worries me – if 1.2 was pushed out with the glaring minVersion bug, then its fix 1.2.1 is hurried out but revived an old 1.1 bug, it just doesn’t bode well for the SDK. I guess I’ll have to test 1.2.1 more before I release my addons on it.

    1. Mingyi Liu

      Oops, I was mistaken about the 1.2 not having the error message. So no issue so far with 1.2.1.

      1. Jeff Griffiths Author

        Mingyi: Actually that error is listed in the ‘known issues’ for 1.2.1:

        https://wiki.mozilla.org/Labs/Jetpack/Release_Notes/1.2.1#Known_Issues

        So it isn’t unexpected that you are seeing that error. I see from the related bugs [1][2] that there is recent discussion and patches; hopefully we can land a fix in this next cycle.

        [1] https://bugzilla.mozilla.org/show_bug.cgi?id=574563
        [2] https://bugzilla.mozilla.org/show_bug.cgi?id=571843

  2. Shobo

    I’m finding really hard to install this addon on my mac, it freezes FF every time. Any suggestions?

    1. Jeff Griffiths Author

      Hi Shobo,

      Which Addon specifically are you having problems with? You can always ask for help with Firefox on Mozilla’s support site:

      http://support.mozilla.com/en-US/home