Add-ons Update – Week of 2013/11/20

Jorge Villalobos

11

I post these updates every 3 weeks to inform add-on developers about the status of the review queues, add-on compatibility, and other happenings in the add-ons world.

The Review Queues

  • Most nominations for full review are taking less than 3 weeks to review.
  • Most updates are being reviewed within 10 days.
  • Most preliminary reviews are being reviewed within 10 days.

These stats are taken from the last queue report:

  • 107 nominations in the queue awaiting review.
  • 75 updates in the queue awaiting review.
  • 101 preliminary review submissions in the queue awaiting review.

If you’re an add-on developer and would like to see add-ons reviewed faster, please consider joining us. Add-on reviewers get invited to Mozilla events and earn cool gear with their work. Visit our wiki page for more information.

Firefox 26 Compatibility

The blog post should be up later this week. Apologies for the delays.

As usual we recommend using the Aurora and Beta branches to test your add-ons ahead of time.

Add-on File Registration Proposal

This is a pretty big deal for all add-on developers, especially those who distribute their add-ons outside of AMO. Please take some time to read the post and the document. If you have any feedback, please comment on the newsgroup and not here. It’s easier to keep all comments in one place so we can revisit them in the future if adjustments are needed.

11 responses

  1. Mindaugas wrote on :

    I think https://developer.mozilla.org/en-US/Firefox/australis-add-on-compat-draft should be included here already. It’s a big change.

    Our add-on was affected

    1. Jorge Villalobos wrote on ::

      I didn’t know about this document. Thank you for bringing it up!

  2. pavel wrote on :

    Hi,

    What can I do / with whom can I speak if I have a super important update for my add-on (currently it doesn’t compatible with FF 25) and can’t wait 10 days for it to get out?

    Thanks

    1. Amy Tsay wrote on ::

      Hi Pavel, you can contact us at amo-editors at mozilla.org or the #amo-editors IRC channel (irc.mozilla.org).

    2. Jorge Villalobos wrote on ::

      Sending a message to the list (like you already did) is the right thing to do. Alternatively you can ask in the #amo-editors channel on IRC.

      1. Pavel wrote on :

        Thanks for the reply here.
        I didn’t get a reply to my email nor in the IRC channel though, so I’m still in the dark about my request…

  3. Mikhoul wrote on ::

    Hi Jorge,

    I fouhd you searching information on a change from Firefox 25 to Firefox 26beta.

    I use an add-on –> https://addons.mozilla.org/en-US/firefox/addon/gpum/

    After my Upgrade to FF26 I found some “graphic” in the add-on interface to be “corrupt” … so I tried to reach the developer to have a fix but he is not able to replicate the bug from what he told me.

    I’ve tested the bug on 2 different computers & the same thing happen with FF26 & as soon I downgrade to FF25 or below it goes away.

    I’m not really a coder more an hacker on the week-end, so I try to have a clue to give the author of the add-on.

    Here’s the discussion on Git-Hub —> https://github.com/mooz/gpum/issues/10 with some ScreenCast (video) of the bug… I’m pretty sure you can point us in the good direction to find what have happened from FF25 to FF26 (We’ve already looked at the developer log for FF26 & found nothing)

    https://github.com/mooz/gpum/issues/10

    Thanks for your help !!!

    1. Jorge Villalobos wrote on ::

      Hello,

      Judging by the video you shot, this appears to be a graphics bug in Firefox, and possibly related to your graphics card and other configuration, which is why it can be difficult to reproduce for people using different hardware.

      I recommend that you file a bug here with all the details you have. Let me know about the bug when you file it, and I’ll try to get some people to look into it.

      Thanks!

      1. Mikhoul wrote on ::

        Thanks a lot Jorge for your help since I not really a developer more a “power user” it will help me (and others) a lot. If you need other information just ask I will do my best to provide you what you need

        Here’s the bug I filled here –>
        https://bugzilla.mozilla.org/show_bug.cgi?id=943569

        Feel free to change anything since English is not my first language ;-)

        p.s. Could you test it on your setup & tell me if it’s happen ?

      2. Mikhoul wrote on ::

        Hi Jorge,

        Do you know if someone will be assigned to look at the bug ?

        Thanks.

        1. Jorge Villalobos wrote on ::

          It might take a while. I’m not familiar with the people who monitor that component, so I don’t know about their response time.