AMO experiencing technical difficulties

Update: as of now (1:10pm PT), it looks like all major features are back to normal.

Due to a recent server migration, AMO has been experiencing some problems for the past few hours. While the site is up, installing and submitting add-ons isn’t working correctly at the moment. The developer and operations team are working hard on fixing these problems as soon as possible and we will update this post once the problems are resolved.

19 responses

  1. Jonathan wrote on :

    Any updates on this yet? ETA for fixing?

    1. Jorge Villalobos wrote on :

      It should be working now.

  2. Fatman wrote on :

    Hmm…

    isup.me reports addons.mozilla.org is up, but the IP my resolver gets (212.159.13.49) is down.

    :/

    1. Jorge Villalobos wrote on :

      Are you still having this problem?

  3. Bob wrote on :

    FYI: Attempted contribution to Download Manager: Oleksandr Popov not functioning as of this time stamp.

    1. Jorge Villalobos wrote on :

      Can you please file a bug with the details?

  4. Tracee wrote on :

    Why are the Themes not updating the number of users? Are there still issues?

    1. Jorge Villalobos wrote on :

      It looks like the stats for all add-ons still need to catch up. This process can take days, so I recommend that you give them another look on Monday and let me know if there’s still missing data.

      1. Tracee wrote on :

        Okay. I’ll keep an eye on them.

      2. custom.firefo.lady wrote on :

        Stats still seem to be empty since last Mon. I’m looking at extensions rather than themes,; likely empty overall.

        1. Jorge Villalobos wrote on :

          Yes, a bug has been filed for it.

          1. Tracee wrote on :

            Yes, stats are still empty for Themes as well.

          2. Tracee wrote on :

            Why are the Themes still not updating? The old ones seem to be but the new ones still say 0.

          3. Jorge Villalobos wrote on :

            Usage stats take a week or two to show up, at least for extensions. If the stats don’t change for any of your new add-ons, please file a new bug.

          4. jen wrote on :

            I have not seen any usage stat updates on any themes since November 9th. That was 20 days ago.

  5. Stefan Pieck wrote on :

    There seems to be an issue that Fully reviewed addons for sideloading are not signed with the correct certificate for example:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1225036
    https://bugzilla.mozilla.org/show_bug.cgi?id=1224807

    may this problem be caused by the migration problems you mentioned?

    1. Jorge Villalobos wrote on :

      Yes, it looks like that’s the case. We’ll sign the add-ons again soon.

      1. Tracee wrote on :

        When will we be seeing usage stat updates for themes? Any known dates? Is there a technical problem?

        1. Jorge Villalobos wrote on :

          There are still some problems happening with all stats. I don’t know how long it will take for them to be fixed, though.