Oct 13

Using Lightning 2.6.* on Linux? Be sure you are using the exact compatible Thunderbird Version

As you may have noticed, Lightning is no longer working with Thunderbird 24.0.1. This is totally unexpected for us, it seems Thunderbird 24.0 and 24.0.1 are not binary compatible. We will be releasing Lightning 2.6.1 this week to fix the issue and afterwards find out how this could have happened.

If you are using Lightning 2.6, please downgrade to Thunderbird 24.0 for now and you will regain access to Lightning and your calendars.

I’m sorry for the inconvenience. Here is the compatibility table:

Thunderbird Version Lightning Version
Thunderbird 24.0 Lightning 2.6
Thunderbird 24.0.1 Lightning 2.6.1
Thunderbird 24.1.0 Lightning 2.6.2
Thunderbird 24.1.1 Lightning 2.6.3
Thunderbird 24.2.0 (unreleased) Lightning 2.6.3 and up

Update 1: This seems to be a Linux-only issue. Windows and Mac users can safely upgrade to Thunderbird 24.0.1!

Update 2: You can get the English version of Thunderbird 24.0 for Linux here. For other languages, please see the release directory on the ftp server.

Update 3: Lightning 2.6.1 is the version compatible to Thunderbird 24.0.1. To date it has not been reviewed by the Mozilla Addons Team, but you can still get it manually using the Other Versions page.

Update 4: Lightning 2.6.1 is now public. On Linux, it is compatible ONLY with Thunderbird 24.0.1, so go ahead and upgrade now.

Update 5: To be more clear: If you are using Thunderbird 24.0 on Linux you MUST continue to use Lightning 2.6. If you are using Thunderbird 24.0.1 on Linux, you MUST use Lightning 2.6.1. Thunderbird 24.1.0 (no typo) will be released soon, you MUST use the upcoming Lightning 2.6.2 here.

Update 6: If you cannot use the newer Lightnig versions yet and want to disable addon updates: Go to the Addons Manager → right click on Lightning → Show More Information → Disable Automatic Updates.

Update 7: Thunderbird 24.1.0 (not .0.1) has just been pushed to the mirrors. On Linux you will need Lightning 2.6.2 together with it. I have heard from some packagers for the Linux distributions that, in contrary to 24.0.1, this version will be made available. If you need Lightning 2.6.2 now, you can get it from the Other Versions page until it has been reviewed.

Update 8: I was now able to set up the version compatibility correctly. If all goes well, Thunderbird 24.0 users should NOT be getting upgrades to Lightning 2.6.1 anymore, all other versions should work correctly too.

Update 9: Updated for 24.1.1 release. The problems are now going away :) I will recap as soon as I get to it.